当前位置: 首页 >> 技术文章 >> 升级更新:Oracle关于DB Link在2019年升级的10g版本兼容性
升级更新:Oracle关于DB Link在2019年升级的10g版本兼容性
发布时间:2018-09-25 发布人:盖国强 1824

在今年3月份,Oracle曾经发布过一则安全预警,题目是:

Oracle Databases Need to be Patched to a Minimum Patchset/PSU/RU level before April 2019 (Doc ID 2361478.1)

Mandatory Patching Requirement for Database Versions 11.2.0.3 or Earlier, Using DB Links (Doc ID 2335265.1)


后来这两篇文章的标题修正为:

Recommended patches and actions for Oracle databases versions 12.1.0.1, 11.2.0.3 and earlier – before June 2019 (Doc ID 2361478.1)

Recommended patching and actions for Oracle database versions 12.1.0.1, 11.2.0.3 and earlier - before June 2019 (Doc ID 2335265.1)


我之前写过几篇文章解析这个问题,其主要原因是 Oracle 将于 2019年6月启用新的SCN兼容性,并且由于BigSCN的作用,96K每秒的SCN增速,都可能会使得通过DB Link的访问产生SCN过度拉升,所以新的补丁需要被应用。


详情参考之前的系列文章:

预警揭秘:倒计时炸弹11.2.0.4前版本DB Link必须在2019年4月升级真相

解决方案:Oracle的 DB Link 问题及2019年4月前升级路线详述

Oracle 的 DBMS_SCN 修正以及 SCN 的 auto-rollover 新特性

更新通报:Oracle全面修正了关于DB Link和SCN补丁的公告

未完待续:关于DB Link和SCN,你还需要知道的是...


最近(2018年8月),相关问题的最新进展被更新,Oracle 提供了针对 Oracle 10g 最终版本 10.2.0.5 的修正补丁,为低版本用户提供了一个解决方案。

Based on customer feedback, we are providing patch on 10.2.0.5. 10g databases requires 10.2.0.5.171017PSU and Patch 14121009. 

Please note that these patches require extended support license.


在推荐的补丁列表中,可以看到最后一行:

1.jpg


针对 10.2.0.5.171017 版本,可以应用补丁 26493118 和 14121009 ,前者是刚刚发布的。属于扩展服务支持范畴。


DATABASE PATCH SET UPDATE 10.2.0.5.171017 and Patch 14121009 [**requires extended support]

<Patch 26493118> and <Patch 14121009> [WIP]

** requires extended support

从MOS上可以看到这个补丁的更新时间是 2018-07-17,Patch 26493118 也就是 Oracle Database Patch Set Update 10.2.0.5.171017。


应用这个修正补丁,可以解决之前的 DB Link 问题。


2.jpg


扩展支持,普通用户是无法下载的,你必须要提供一个口令,才能继续下载:


3.jpg


对于 Oracle 10g 的用户,现在终于有了选择,可以不必急着进行大版本的升级了。请 10g 的用户关注这个版本升级。


然而,随着时间的推移,所有Oracle用户都应该来正视这个问题,开始着手制定解决方案了。


4.jpg